Справка по AutoCAD

Справка по AutoCAD 2007 для разработчиков приложений

Добро пожаловать в справочную систему по AutoCAD 2007 для разработчиков

Справка по AutoCAD для разработчиков приложений содержит исчерпывающую информацию по настройке и расширению AutoCAD. Для поиска разделов можно воспользоваться ссылками справа или вкладкой "Содержание".

Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX

Мои разделы
Интернет-ресурсы


Руководство по настройке

В Руководстве по настройке приведена информация по настройке AutoCAD, предназначенная для опытных пользователей. Для просмотра Руководства по настройке используйте вкладку "Содержание" в левой части окна "Справка".

  • Основные принципы настройки
  • Настройка типов линий
  • Пользовательские образцы штриховки
  • Настройка интерфейса пользователя
  • DIESEL
  • Слайды и командные сценарии
  • Введение в интерфейсы программирования
  • Формы и шрифты
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


AutoLISP Reference

AutoLISP Reference представляет собой полное справочное руководство по AutoLISP® — интерпретируемому языку программирования, который служит для обращения к командам AutoCAD, системным переменным и диалоговым окнам. Перечень разделов документа AutoLISP Reference:

  • AutoLISP Functions: Operators, A, B, C, D, E, F, G, H, I, J, K, L, M, N, O, P, Q, R, S, T, U, V, W, X, Y, Z.
  • Externally Defined Commands
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


AutoLISP Developer's Guide

AutoLISP Developer's Guide содержит сведения о работе в интегрированной среде разработки приложений Visual LISP®, которая служит для разработки и тестирования программ на языке AutoLISP. Здесь также описывается использование расширений Visual LISP для создания приложений с использованием технологии ActiveX® Automation. Перечень разделов документа AutoLISP Developer's Guide:

  • Introduction
  • Using the Visual LISP Environment
  • Using the AutoLISP Language
  • Working with Programmable Dialog Boxes
  • Appendixes
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


Учебное пособие по AutoLISP

Учебное пособие по AutoLISP содержит упражнения с пошаговыми инструкциями, иллюстрирующие на практике использование Visual LISP™ для разработки программ на языке AutoLISP®. Перечень разделовУчебного пособия по AutoLISP:

  • Введение
  • Постановка задачи и начало программирования
  • Средства отладки Visual LISP
  • Построение контура дорожки
  • Создание проекта и добавление элементов интерфейса
  • Создание плиток
  • Использование реакторов
  • Окончательная компоновка
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


DXF Reference

Документ DXF Reference содержит полное и исчерпывающее описание формата файлов DXF™. Перечень разделов документа DXF Reference

  • DXF Format
  • HEADER Section
  • CLASSES Section
  • TABLES Section
  • BLOCKS Section
  • ENTITIES Section
  • OBJECTS Section
  • THUMBNAILIMAGE Section
  • Drawing Interexchange File Formats
  • Advanced DXF Issues
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


ActiveX and VBA Developer's Guide

В документе ActiveX and VBA Developer's Guide разъясняется использование ActiveX и VBA для разработки приложений к AutoCAD. Документ включает в себя примеры программ и пошаговые инструкции. Перечень разделов документа ActiveX and VBA Developer's Guide:

  • Introduction
  • Getting Started with VBA
  • ActiveX Automation Basics
  • Control the AutoCAD Environment
  • Create and Edit AutoCAD Entities
  • Dimensions and Tolerances
  • Customize Toolbars and Menus
  • Use Events
  • Work in Three-Dimensional Space
  • Define Layouts and Plot
  • Advanced Drawing and Organizational Techniques
  • Develop Applications with VBA
  • Interact with Other Applications and Windows APIs
  • Design the Garden Path--An ActiveX/VBA Tutorial
  • Visual LISP and ActiveX/VBA Comparison
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


ActiveX and VBA Reference

В документе ActiveX and VBA Reference содержатся сведения об объектной модели ActiveX и о связанных компонентах интерфейса. Перечень разделов документа ActiveX and VBA Reference:

  • Object Model
  • Events
  • Methods
  • Properties
  • Objects
  • Code Examples
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


Sheet Set Objects Reference

В документе Sheet Set Objects Reference содержатся сведения об объектах Диспетчера подшивок. Перечень разделов документа Sheet Set Objects Reference:

  • Overview of Sheet Set Manager Objects
  • Objects
  • Methods
  • Properties
  • Enums
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


Connectivity Automation Manager

Документ Connectivity Automation Manager содержит сведения об объектной модели архитектуры Automation и о связанных компонентах интерфейса. Перечень разделов документа Connectivity Automation Manager:

  • Connectivity Automation Objects
  • Object Model
  • Objects
  • Methods
  • Properties
  • Events
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


ObjectARX

ObjectARX®, (среда программирования AutoCAD® Runtime Extension) включает в себя библиотеки для языка C++, с помощью которых можно разрабатывать приложения для AutoCAD, расширять набор классов и протоколов AutoCAD, а также создавать новые команды, неотличимые по способам выполнения от встроенных команд AutoCAD.

Если этот документ выглядит на вкладке "Содержание" Справки как значок странички ( [image]), документация по ObjectARX пока отсутствует на данном компьютере.

Документацию по AutoCAD ObjectARX можно загрузить из раздела Центр разработчика веб-узла Autodesk. Для включения документации по ObjectARX в документацию AutoCAD необходимо скопировать файлы справки ObjectARX в папку AutoCAD \HELP\.
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


Мои разделы

Пользователь может самостоятельно создавать разделы справочной системы. Добавленные разделы доступны из вкладок "Содержание", "Указатель" (если в них имеются элементы указателя) и "Поиск" в левой панели окна "Справка". Чтобы обратиться к добавленным разделам, следует выбрать на вкладке "Содержание" элемент "Мои разделы".

Информация о заполнении вкладки "Мои разделы" содержится в документации Заполнение "Моих разделов".
Общие сведения

Справочные документы

Руководство по настройке

AutoLISP Reference

AutoLISP Developer's Guide

Учебное пособие по AutoLISP

DXF Reference

ActiveX and VBA Developer's Guide

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Manager

ObjectARX


Информация о версии справки


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Примечание: Форма не предназначена для получения советов или технической поддержки. Ваша информация будет использована для улучшения документации по продукту. Благодарим Вас!


AnswerWorks®


Советы по созданию запросов

Следуя нижеперечисленным советам, можно получить наиболее точные ответы на поставленные вопросы.

  • Чтобы ограничить область поиска, выберите именно те разделы документации, в которых вероятнее всего можно найти требуемую информацию. Выберите папки или набор папок из "Списка разделов документации для поиска" (List of Documentation Components to Search).
  • Проверьте, нет ли в вопросе опечаток. Значимые слова могут игнорироваться, если их невозможно распознать.
  • Запросы следует оформлять в виде вопросов (Как отключить диалоговые окна?), в виде фраз (отключение диалоговых окон) или ключевых слов (диалоговое окно). При этом результаты, полученные в ответ на подобные запросы, могут несколько отличаться.
  • Запрос не должен быть многословным. Зачастую, чем меньше вводится слов, тем точнее результат запроса.
    Пример: Список разделов, полученный по запросу Максимальное число видовых экранов, отличается от списка разделов по запросу Как увеличить максимальное число отображаемых видовых экранов?
  • Изменяйте порядок слов в запросе. Порядок слов может повлиять на результат.
    Пример: Результат по запросу максимальное число видовых экранов отличается от результата по запросу видовых экранов максимальное число.
  • Используйте в запросе различные, но сходные по значению слова и выражения.
    Пример: Запросы чертить окружности и создать окружности дают несколько отличающиеся результаты.
    Пример: Результат запроса диалоговые окна отличается от результата запроса диалоги.
  • В запросах не следует использовать знаки пунктуации. Если термины, которые необходимо найти, содержат знаки пунктуации, поиск следует осуществлять с помощью вкладки "Поиск".
    Пример: Если ввести имя файла, например acad.pat, то результат поиска будет недостоверным.
  • В запросах не следует употреблять цифры.
    Пример: Если ввести термин, в написании которого используется сочетание 3D, результат поиска будет недостоверным. В данном случае вместо 3D следует писать трехмерный.
  • Не следует вводить слова, которые часто используются в формулировках разделов справочной системы.
    Пример: При вводе слова чертеж или линия, вероятно, результаты поиска будут искажены. Рекомендуется удалить подобные слова из запроса или использовать более точные понятия.


Авторские права и товарные знаки

Copyright © 2006 Корпорация Autodesk.

С сохранением всех прав

Данная публикация или какая-либо ее часть не могут быть воспроизведены в каком бы то ни было виде, независимо от способа и целей копирования.

КОРПОРАЦИЯ AUTODESK НЕ ПРЕДОСТАВЛЯЕТ ГАРАНТИЙ, ВЫРАЖЕННЫХ В ЯВНОЙ ФОРМЕ ИЛИ ПОДРАЗУМЕВАЕМЫХ, ВКЛЮЧАЯ ПОДРАЗУМЕВАЕМЫЕ ГАРАНТИИ ПРИГОДНОСТИ ДАННЫХ МАТЕРИАЛОВ ДЛЯ ПРОДАЖИ ИЛИ ДЛЯ ДРУГИХ КОНКРЕТНЫХ ЦЕЛЕЙ, НО НЕ ОГРАНИЧИВАЯСЬ ИМИ, И ПРЕДОСТАВЛЯЕТ ЭТИ МАТЕРИАЛЫ ИСКЛЮЧИТЕЛЬНО НА УСЛОВИЯХ "КАК ЕСТЬ".

КОРПОРАЦИЯ AUTODESK НИ ПРИ КАКИХ ОБСТОЯТЕЛЬСТВАХ НЕ НЕСЕТ НИ ПЕРЕД КЕМ ОТВЕТСТВЕННОСТИ ЗА ОПРЕДЕЛЯЕМЫЕ ОСОБЫМИ ОБСТОЯТЕЛЬСТВАМИ, СОПУТСТВУЮЩИЕ, ПОБОЧНЫЕ ИЛИ КОСВЕННЫЕ УБЫТКИ, ВОЗНИКШИЕ В СВЯЗИ С ПРИОБРЕТЕНИЕМ ИЛИ ИСПОЛЬЗОВАНИЕМ ДАННЫХ МАТЕРИАЛОВ ИЛИ В РЕЗУЛЬТАТЕ ЭТОГО. ЕДИНСТВЕННАЯ И ИСКЛЮЧИТЕЛЬНАЯ ОТВЕТСТВЕННОСТЬ КОРПОРАЦИИ AUTODESK, НЕЗАВИСИМО ОТ ФОРМЫ ДЕЯТЕЛЬНОСТИ, НЕ БУДЕТ ПРЕВЫШАТЬ ПРОДАЖНУЮ ЦЕНУ ОПИСАННЫХ ЗДЕСЬ МАТЕРИАЛОВ.

Корпорация Autodesk оставляет за собой право модификации и усовершенствования своей продукции по мере необходимости. Данное руководство описывает программное обеспечение по состоянию на момент публикации, поэтому может не отражать последующие изменения программы.

Товарные знаки Autodesk

Следующие названия являются товарными знаками корпорации Autodesk в США и в других странах: 3D Studio, 3D Studio MAX, 3D Studio VIZ, 3ds Max, ActiveShapes, Actrix, ADI, AEC-X, ATC, AUGI, AutoCAD, AutoCAD LT, Autodesk, Autodesk Envision, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk Streamline, Autodesk WalkThrough, Autodesk World, AutoLISP, AutoSketch, Backdraft, Bringing information down to earth, Buzzsaw, CAD Overlay, Character Studio, Cinepak, Cinepak (логотип), Civil 3D, Cleaner, Combustion, Design Your World, Design Your World (логотип), EditDV, Education by Design, Gmax, Heidi, HOOPS, i-drop, IntroDV, Lustre, Mechanical Desktop, ObjectARX, Powered with Autodesk Technology (логотип), ProjectPoint, RadioRay, Reactor, Revit, Visual, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Toolbox, Visual Tugboat, Visual LISP, Volo, WHIP! и WHIP! (логотип)

Следующие названия являются товарными знаками корпорации Autodesk в США и в других странах: AutoCAD Learning Assistance, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, AutoSnap, AutoTrack, Built with ObjectARX (логотип), Burn, CAiCE, Cinestream, Cleaner Central, ClearScale, Colour Warper, Content Explorer, Dancing Baby (изображение), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, Design Web Format, DWF, DWFit, DWG Linking, DWG TrueConvert, DWG TrueView, DXF, Extending the Design Team, GDX Driver, Gmax (логотип), Gmax ready (логотип), Heads-up Design, Incinerator, jobnet, LocationLogic, ObjectDBX, Plasma, PolarSnap, Productstream, RealDWG, Real-time Roto, Render Queue, Topobase, Toxik, Visual Bridge, Visual Syllabus и Wiretap.

Корпорация Autodesk Canada Co. Товарные знаки

В США, Канаде и/или других странах товарными знаками корпорации Autodesk Canada Co. являются: Discreet, Fire, Flame, Flint, Flint RT, Frost, Glass, Inferno, MountStone, Riot, River, Smoke, Sparks, Stone, Stream, Vapour, Wire.

Следующие названия являются товарными знаками корпорации Autodesk Canada Co. в США, Канаде и/или других странах: Backburner, Multi-Master Editing.

Товарные знаки других фирм

Все остальные названия и товарные знаки принадлежат соответствующим владельцам.

Сторонние разработчики программного обеспечения

ACIS Copyright © 1989-2001 Spatial Corp. Частично Copyright © 2002 Autodesk, Inc.

AnswerWorks 4.0 ©; 1997-2003 WexTech Systems, Inc. Частично основано на данном программном обеспечении © Vantage-Knexys. С сохранением всех прав.

Copyright © 1997 Microsoft Corporation. С сохранением всех прав.

Copyright © 1988-1997 Sam Leffler.

Copyright © 1991-1997 Silicon Graphics, Inc.

AutoCAD ® 2007 и AutoCAD LT ® 2007 производится согласно лицензии, полученной у DIC Color Guide ® from Dainippon Ink and Chemicals, Inc. Copyright © Dainippon Ink and Chemicals, Inc. С сохранением всех прав. DIC и DIC Color Guide являются зарегистрированными товарными знаками компании Dainippon Ink and Chemicals, Inc.

International CorrectSpell™. Система проверки орфографии © Lernout & Hauspie Speech Products, N.V., 1995 г. С сохранением всех прав.

InstallShield™ 3.0. Copyright © 1997 InstallShield Software Corporation. С сохранением всех прав.

Macromedia ® and Flash ® являются охраняемыми товарными знаками компаний Adobe Systems Incorporated в США и других странах.

PANTONE® Цвета, отображаемые в программном обеспечении и в пользовательской документации, могут не соответствовать стандартам PANTONE. Точность отображения цвета следует проверять по подлинным публикациям цветов компании PANTONE.

PANTONE ® и другие товарные знаки Pantone, Inc. принадлежат компании Pantone, Inc. © Pantone, Inc. 2002

Корпорация Pantone является владельцем авторских прав на программное обеспечение и/или на данные по цветопередаче, лицензия на которые предоставлена корпорации Autodesk только на условиях их распространения для использования исключительно в сочетании с определенными программными продуктами Autodesk. Компания Pantone, Inc. является владельцем авторских прав на цветовые данные и/или программное обеспечение, которые переданы по лицензии компании Autodesk, Inc., для распространения и использования только с определенными программными продуктами компании Autodesk.

Частично © 1991-1996 гг. Arthur D. Applegate. С сохранением всех прав.

Данное программное обеспечение частично основано на разработках независимой группы JPEG.

RAL DESIGN © RAL, Sankt Augustin, 2002

RAL CLASSIC © RAL, Sankt Augustin, 2002

Отображение с передачей цветов RAL выполнено с разрешения RAL Deutsches Institut für Gütesicherung und Kennzeichnung e.V. (Немецкого Института RAL по сертификации и поддержке качества, бывшей Assoc.), D-53757 Sankt Augustin."

Гарнитуры шрифтов из библиотеки гарнитур Bitstream® , © 1992 г.

Гарнитуры шрифтов от Payne Loving Trust, © 1996 г © 1996. С сохранением всех прав.

Печатное руководство и справка выполнены с помощью Idiom WorldServer™

ИСПОЛЬЗОВАНИЕ В ГОСУДАРСТВЕННЫХ УЧРЕЖДЕНИЯХ

Использование, копирование или разглашение государственными учреждениями США допускаются в рамках применимых ограничений, сформулированных в FAR 12.212 (Ограничения в правах на программное обеспечение для коммерческих компьютеров) и DFAR 227.7202 (Права на технические данные и программное обеспечение компьютеров).


Заполнение "Моих разделов"

Для добавления справочных сведений в "Мои разделы" необходимо вначале создать их в формате HTML, а затем скомпилировать программой Microsoft HTML Help Workshop. Результатом компиляции является файл myhelp.chm. Этот файл следует поместить в папку AutoCAD\Help.

Включение подразделов в "Мои разделы"

  • Добавить к числу исходных компилируемых файлов файл со списком подразделов. Он должен иметь имя myhelp_toc.html.

Отображение заголовков подразделов на вкладке "Содержание"

  • Добавить к числу исходных компилируемых файлов HHC-файл содержимого.

Возможность поиска разделов по ключевым словам

  • Добавить к числу исходных компилируемых файлов HHK-файл указателя.

Если в CHM-файл пользовательской справки не включены файл myhelp_toc.html, HHC-файл или HHK-файл, просмотреть содержимое "Моих разделов" можно с помощью вкладки "Поиск".

В комплект поставки продукта включены файлы примеров организации "Моих разделов". Извлечь файлы примеров из архивного файла myhelp.zip.


zz [Пустой раздел]

Пустой раздел

Этот раздел намеренно оставлен пустым.